Рейтинг: 110.0234  
Внедрено
Предложил Харахнин Станислав 17.08.2017 10:56:47

PHP 7.2 Устарел mbstring.func_overload

Здравствуйте.

Коллеги, сейчас читал спецификацию по релизу PHP 7.2. Считаю важным обратить внимание разработчиков на важные момент. В данной версии mbstring.func_overload считается устаревшим и при не нулевом значении будет выбрасываться Deprecation notice. Это еще не критично, но стоит задуматься. Сейчас в битриксе при работе в uft-8 кодировке значение mbstring.func_overload = 2 является обязательным. Иначе сайт может не корректно работать.

Время еще есть, но предлагаю уже сейчас принимать это во внимание и начать процесс по устранению данной проблемы в будущем.

Список изменений можно посмотреть тут и конкретно по mbstring.func_overload тут

Нашел такую же идею тут. Нет возможности удалить, поэтому прошу голосовать в теме другого автора
Рейтинг: 2  
Ответил Жуков Евгений 22.09.2020 15:59:07
Доступны дистрибутивы 20.5.393. Для существующих проектов - выпущены или тестируются обновления модулей (за исключением модуля compression - снят с использования, необходимо удалить).