Минимальная версия php для работы платформы

Рейтинг: 4.8664  
Внедрено
Предложил Николаев Андрей 13.06.2017 13:18:43

Минимальная версия php для работы платформы

Может быть предлагаю что-то революционное, но прошу рассмотреть возможность увеличения минимальной версии php для работы.
Для сохранения обратной совместимости предлагаю начать с версии php5.4

То есть:
- В конце 2017 года объявить минимальную поддерживаемую версию - php5.4
- В конце 2018 года отказаться от php5.4 - 5.6 выставив минимальной версию - php 7.0


P.S. А то просто непонятно как так получается - всем рекомендуете перейти на php7.0, при этом в тот же маркетплейс требуете php5.3

Рейтинг: 1.0631  
Семёнов Роман 15.06.2017 08:56:58
люто плюсую.

только пора уже php 7 сделать минимальной версией - в виртуальном окружении она уже есть.
а про php5 забыть уже пора.
Рейтинг: -0.5459  
Балабанов Богдан 15.06.2017 12:24:45
Даже PHP 5.6 пока рано еще тонны модулей и компонентов переписывать, а вот 5.4- самое оно.
Плюсую.