Модернизировать систему обновлений

Рейтинг: 2.5806  
На голосовании
Предложил Пользователь 23748 28.04.2015 09:24:05

Модернизировать систему обновлений

Хочется при установке обновлений иметь возможность расширенной настройки установки апдейтов.
А именно каждый модуль иметь возможность устанавливать чекбоксами каждую версию, чтобы например иметь возможность поставить не все релизы а только выборочные

например стоит у нас версия главного модуля 14,0,1 я бы хотел иметь возможность поставить не все апдейты разом а только напримаер до версии 14,5,0 ну и аналогично так же с модулями МП.
Рейтинг: 0  
Ответил 28.04.2015 18:47:53
Для меня как для человека (не сотрудника компании), что 14.0.1, что 14.5.1 не имеет значения, я не отслеживаю изменения, не знаю, что выбирать, поэтому данная настройка выглядит сомнительной, но посмотрим на голосование.

Рейтинг: 1.6434  
Пользователь 1756 28.04.2015 20:08:01
Приведу живой пример в пользу данной идеи.
Недавно была выпущена версия модуля fileman 15.0.4 с синтаксической ошибкой. Я об этом узнал по тестам на виртуалке. И до момента выхода версии 15.0.5 я не мог вообще обновлять этот модуль на боевом сайте. Тогда как при реализации данной идеи я мог бы обновиться до версии 15.0.3.

Лучше получить только часть обновлений, нежели получить нежелательное обновление или оставаться вовсе без обновлений.
Рейтинг: 1.1315  
Пользователь 23748 29.04.2015 07:31:46
Михаил как раз и описал ситуацию почему это надо сделать, обывателям это понятно незачем а разработчикам и тем кто оказывает тех поддержку очень бы даже нужно.
Рейтинг: 0.5119  
Пользователь 39858 30.04.2015 08:19:57
Банальный пример - необходимо обновиться до последней версии предыдущего релиза, так как новый релиз пока не нужен по какой-либо причине или заведомо известны ошибки. А если хоть один модуль из обновляемых перевалил версию - он по зависимостям может потащить весь релиз за собой, мне это сейчас не надо.
Я обновляюсь, например, перед выпуском следующего релиза, т.е. почти раз в полгода, когда текущий уже доведут до стабильного состояния, а новых заморочек ещё не выпустили. Но так как дата появления модулей от нового релиза в системе обновлений заранее неизвестна - то это лотерея. Не угадал и модули до конечной версии предыдущего релиза обновить уже не сможешь, только до нового.
Рейтинг: 0  
Пользователь 39858 30.04.2015 08:21:42
Предложенная Александром система может и немного избыточна в плане технической реализации (учёт тех же зависимостей), меня бы, например, вполне устроила возможность обновиться до последней версии определённого релиза.
Рейтинг: 0  
Пользователь 129131 05.05.2015 16:31:53
Для меня как для человека (не сотрудника компании), что 14.0.1, что 14.5.1 не имеет значения, я не отслеживаю изменения, не знаю, что выбирать, поэтому данная настройка выглядит сомнительной, но посмотрим на голосование.
Детали важней всего...